Home Forum Sailfish OS Applicazioni Incompatibilità apk

Questo argomento contiene 2 risposte, ha 2 partecipanti, ed è stato aggiornato da  al3ssio 7 mesi, 2 settimane fa.

Stai vedendo 3 articoli - dal 1 a 3 (di 3 totali)
  • Autore
    Articoli
  • #9279

    al3ssio
    Partecipante
    • 3 discussioni
    • 4 risposte
    Karma: 51.00 karma

    premetto che sono nuovo

    mi sembra di capire che le app per cui è necessario android 4.3 o superiore non girano sul jolla, mi sbaglio?

    #9280

    Paolo M.
    Partecipante
    • 15 discussioni
    • 236 risposte
    Karma: 1 440.00 karma

    sul telefono jolla, vecchio di almeno 3 anni, attualmente sono supportate le applicazioni android fino a 4.1.2. Sullo Jolla C (e aquafish) la compatibilità arriva fino a 4.4.4.

    La spiegazione è che le versioni nuove della dalvik vm richiedono una certa versione del kernel linux, ma sul vecchio jolla non possono aggiornare il kernel perché la qualcomm non rilascia loro i driver per i kernel recenti, mentre sui più recenti jolla c e aquafish c’è già una versione sufficientemente aggiornata del kernel (e dei driver qualcomm). Morale: ricordatevi che aveva ragione Stallman!

    ps: il comando per verificare la versione di android compatibile su un generico smartphone sailfish os (con dalvik) è il seguente:

    grep ‘version.release\|model’ /opt/alien/system/build.prop

    #9288

    al3ssio
    Partecipante
    • 3 discussioni
    • 4 risposte
    Karma: 51.00 karma

    grazie per l’info e la triste conferma!

    • Questa risposta è stata modificata 7 mesi, 2 settimane fa da  al3ssio.
Stai vedendo 3 articoli - dal 1 a 3 (di 3 totali)

Devi essere loggato per rispondere a questa discussione.